$re = '/^[2-9]{1}[0-9]{9}$/';
$str = '2548765425';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);