import re
regex = re.compile(r"(^([0-9]{2,3}.)([0-9]{2,3}.)([0-9]{2,3}.)([0-9]{2,3})$)", flags=re.MULTILINE)
test_str = ("00.123.55.44\n"
"000.12.12.034\n"
"121.234.12.12\n"
"23.45.12.56\n"
"00.12.123.123123.123\n"
"122.23\n"
"Hello.IP")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")