#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'big'[a-zA-Z0-9]+)(,(?&big))*$"
Local $sString = "aaa" & @CRLF & _
"aaa,bbb" & @CRLF & _
"aaa,bbb,ccc" & @CRLF & _
"aaa," & @CRLF & _
"aaa,bbb," & @CRLF & _
"aaa,bbb,cccá" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")