$re = '/^(?\'big\'[a-zA-Z0-9]+)(,(?&big))*$/m';
$str = 'aaa
aaa,bbb
aaa,bbb,ccc
aaa,
aaa,bbb,
aaa,bbb,cccá
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);