#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=(?:(?!(?:post office|po)[\h,.-]?box).)*$)[\w\h,.-]+$"
Local $sString = "this should match" & @CRLF & _
"and this too" & @CRLF & _
"" & @CRLF & _
"Test Po Box - Should NOT be acceptable" & @CRLF & _
"Test Post Office Box - Should NOT be acceptable" & @CRLF & _
"Test Po,Box - Should NOT be acceptable" & @CRLF & _
"Test PO BOx - Should NOT be acceptable" & @CRLF & _
"Test-123po - Should be acceptable" & @CRLF & _
"Test-!@$% - Should NOT be acceptable" & @CRLF & _
"Test123@#$ PoBOX - Should NOT be acceptable."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")