$re = '/^(?=(?:(?!(?:post office|po)[\h,.-]?box).)*$)[\w\h,.-]+$/mi';
$str = 'this should match
and this too
Test Po Box - Should NOT be acceptable
Test Post Office Box - Should NOT be acceptable
Test Po,Box - Should NOT be acceptable
Test PO BOx - Should NOT be acceptable
Test-123po - Should be acceptable
Test-!@$% - Should NOT be acceptable
Test123@#$ PoBOX - Should NOT be acceptable.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);