package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^\S\r\n]*\d+\.\d{2}(?:[^\S\r\n]*\r?\n[^\S\r\n]*\d+\.\d{2})*[^\S\r\n]*$`)
var str = ` 123.32
234.54
456.43 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}