re = /^[^\S\r\n]*\d+\.\d{2}(?:[^\S\r\n]*\r?\n[^\S\r\n]*\d+\.\d{2})*[^\S\r\n]*$/
str = ' 123.32
234.54
456.43 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end