package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([0-9]*)([\S\s]*)`)
var str = `11b- 5d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}