$re = '/([0-9]*)([\S\s]*)/i';
$str = '11b- 5d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);