$re = '/.*\//';
$str = 'c://nicola/Onedrive/file.doc';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;