import re
regex = re.compile(r".*\/")
test_str = "c://nicola/Onedrive/file.doc"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)