using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^01\d{0-9}$";
string input = @"RegExr v3 was created by gskinner.com, and is proudly hosted by Media Temple.
01123456789
a01361812429
01361812429898980936181242998989878
Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & Javascript flavors of RegEx are supported.
The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community, and view patterns you create or favorite in My Patterns.
Explore results with the Tools below. Replace & List output custom results. Details lists capture groups. Explain describes your expression in plain English.
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}