package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^01\d{0-9}$`)
var str = `RegExr v3 was created by gskinner.com, and is proudly hosted by Media Temple.
01123456789
a01361812429
01361812429898980936181242998989878
Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & Javascript flavors of RegEx are supported.
The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community, and view patterns you create or favorite in My Patterns.
Explore results with the Tools below. Replace & List output custom results. Details lists capture groups. Explain describes your expression in plain English.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}