package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([aeiouAEIOU][a-zA-Z]+)|(([qwrtpsdfghjklzxcvbnmyQWRTPSDFGHJKLZXCVBNMY]+)([a-zA-Z]+))`)
var str = `Hello there, animal. Banana banana`
var substitution = "$3iggedy $1$3$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}