$re = '/([aeiouAEIOU][a-zA-Z]+)|(([qwrtpsdfghjklzxcvbnmyQWRTPSDFGHJKLZXCVBNMY]+)([a-zA-Z]+))/';
$str = 'Hello there, animal. Banana banana';
$subst = "$3iggedy $1$3$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;