import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://stackoverflow\\.com/users/(\\d{1,9})/user\\1";
final String string = "https://stackoverflow.com/users/12283851/user12283851 <== Valid\n"
+ "https://stackoverflow.com/users/11111111/user12283851 <== Invalid";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}