re = /https?:\/\/stackoverflow\.com\/users\/(\d{1,9})\/user\1/m
str = 'https://stackoverflow.com/users/12283851/user12283851 <== Valid
https://stackoverflow.com/users/11111111/user12283851 <== Invalid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end