$re = '/^[a-z0-9]+([\-][a-z0-9]+)*$/m';
$str = 'adhfjkhakldf
adhfjkhakldf-asdfhjkhadsfkh
dsafasdf98980
kladjlasjd laksjdlasj
klsdfjlksadj asdklfjlsdajfl
klsadjflkdjsaf ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);