re = /^[a-z0-9]+([\-][a-z0-9]+)*$/m
str = 'adhfjkhakldf
adhfjkhakldf-asdfhjkhadsfkh
dsafasdf98980
kladjlasjd laksjdlasj
klsdfjlksadj asdklfjlsdajfl
klsadjflkdjsaf '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end