import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*)(http\\S+)(.*)$";
final String string = "sublimetext macro\n"
+ "https://sublime-text-unofficial-documentation.readthedocs.io/en/stable/core/commands.html\n"
+ "https://docs.sublimetext.io/reference/commands.html#commands\n"
+ " https://docs.sublimetext.io/guide/extensibility/snippets.html#substitutions\n"
+ "sublime text macro replace text";
final String subst = "$1* <$2>$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}