// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\s*)(http\S+)(.*)$").unwrap();
let string = "sublimetext macro
https://sublime-text-unofficial-documentation.readthedocs.io/en/stable/core/commands.html
https://docs.sublimetext.io/reference/commands.html#commands
https://docs.sublimetext.io/guide/extensibility/snippets.html#substitutions
sublime text macro replace text";
let substitution = "$1* <$2>$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}