#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(>[^<\/\nA-Za-z]{0,5})\Qfloat\E([^>\/\nA-Za-z]{0,5}<)"
Local $sString = "<div>" & @CRLF & _
"<p style="text-align: left;">Style: <span style="float: right;">Casual</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Color: <span style="float: right;">float</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Pattern Type: <span style="float: right;">Letter</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Neckline: <span style="float: right;">Round Neck</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Length: <span style="float: right;">Regular</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Type: <span style="float: right;">Pullovers</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Details: <span style="float: right;">Frill</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Sleeve Length: <span style="float: right;">Long Sleeve</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Sleeve Type: <span style="float: right;">Drop Shoulder</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Season: <span style="float: right;">Spring/Fall</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Composition: <span style="float: right;">5% Spandex</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Composition: <span style="float: right;">95% Polyester</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Fabric: <span style="float: right;">Slight Stretch</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
"<p style="text-align: left;">Fit Type: <span style="float: right;">Regular Fit</span></p>" & @CRLF & _
"</div>" & @CRLF & _
"<p></p>" & @CRLF & _
"<table border="1">" & @CRLF & _
"<thead>" & @CRLF & _
"<tr>" & @CRLF & _
"<th>size</th>" & @CRLF & _
"<th>Shoulder</th>" & @CRLF & _
"<th>Bust</th>" & @CRLF & _
"<th>Length</th>" & @CRLF & _
"<th>Sleeve Length</th>" & @CRLF & _
"<th>Bicep Length</th>" & @CRLF & _
"<th>Cuff</th>" & @CRLF & _
"</tr>" & @CRLF & _
"</thead>" & @CRLF & _
"<tbody>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>XS</td>" & @CRLF & _
"<td>63 cm</td>" & @CRLF & _
"<td>104 cm</td>" & @CRLF & _
"<td>63 cm</td>" & @CRLF & _
"<td>51 cm</td>" & @CRLF & _
"<td>45 cm</td>" & @CRLF & _
"<td>17 cm</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>S</td>" & @CRLF & _
"<td>64 cm</td>" & @CRLF & _
"<td>108 cm</td>" & @CRLF & _
"<td>64 cm</td>" & @CRLF & _
"<td>52 cm</td>" & @CRLF & _
"<td>46 cm</td>" & @CRLF & _
"<td>18 cm</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>M</td>" & @CRLF & _
"<td>65 cm</td>" & @CRLF & _
"<td>112 cm</td>" & @CRLF & _
"<td>65 cm</td>" & @CRLF & _
"<td>53 cm</td>" & @CRLF & _
"<td>47 cm</td>" & @CRLF & _
"<td>19 cm</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td>L</td>" & @CRLF & _
"<td>66 cm</td>" & @CRLF & _
"<td>116 cm</td>" & @CRLF & _
"<td>66 cm</td>" & @CRLF & _
"<td>54 cm</td>" & @CRLF & _
"<td>48 cm</td>" & @CRLF & _
"<td>20 cm</td>" & @CRLF & _
"</tr>" & @CRLF & _
"</tbody>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")