import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(>[^<\\/\\nA-Za-z]{0,5})\\Qfloat\\E([^>\\/\\nA-Za-z]{0,5}<)";
final String string = "<div>\n"
+ "<p style=\"text-align: left;\">Style: <span style=\"float: right;\">Casual</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Color: <span style=\"float: right;\">float</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Pattern Type: <span style=\"float: right;\">Letter</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Neckline: <span style=\"float: right;\">Round Neck</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Length: <span style=\"float: right;\">Regular</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Type: <span style=\"float: right;\">Pullovers</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Details: <span style=\"float: right;\">Frill</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Sleeve Length: <span style=\"float: right;\">Long Sleeve</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Sleeve Type: <span style=\"float: right;\">Drop Shoulder</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Season: <span style=\"float: right;\">Spring/Fall</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Composition: <span style=\"float: right;\">5% Spandex</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Composition: <span style=\"float: right;\">95% Polyester</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Fabric: <span style=\"float: right;\">Slight Stretch</span></p>\n"
+ "</div>\n"
+ "<div>\n"
+ "<p style=\"text-align: left;\">Fit Type: <span style=\"float: right;\">Regular Fit</span></p>\n"
+ "</div>\n"
+ "<p></p>\n"
+ "<table border=\"1\">\n"
+ "<thead>\n"
+ "<tr>\n"
+ "<th>size</th>\n"
+ "<th>Shoulder</th>\n"
+ "<th>Bust</th>\n"
+ "<th>Length</th>\n"
+ "<th>Sleeve Length</th>\n"
+ "<th>Bicep Length</th>\n"
+ "<th>Cuff</th>\n"
+ "</tr>\n"
+ "</thead>\n"
+ "<tbody>\n"
+ "<tr>\n"
+ "<td>XS</td>\n"
+ "<td>63 cm</td>\n"
+ "<td>104 cm</td>\n"
+ "<td>63 cm</td>\n"
+ "<td>51 cm</td>\n"
+ "<td>45 cm</td>\n"
+ "<td>17 cm</td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<td>S</td>\n"
+ "<td>64 cm</td>\n"
+ "<td>108 cm</td>\n"
+ "<td>64 cm</td>\n"
+ "<td>52 cm</td>\n"
+ "<td>46 cm</td>\n"
+ "<td>18 cm</td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<td>M</td>\n"
+ "<td>65 cm</td>\n"
+ "<td>112 cm</td>\n"
+ "<td>65 cm</td>\n"
+ "<td>53 cm</td>\n"
+ "<td>47 cm</td>\n"
+ "<td>19 cm</td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ "<td>L</td>\n"
+ "<td>66 cm</td>\n"
+ "<td>116 cm</td>\n"
+ "<td>66 cm</td>\n"
+ "<td>54 cm</td>\n"
+ "<td>48 cm</td>\n"
+ "<td>20 cm</td>\n"
+ "</tr>\n"
+ "</tbody>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}