#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0,(?!0,)[^,]+,1,(?!0)[^,]+$"
Local $sString = "1,0,0,0" & @CRLF & _
"0,100,0,0" & @CRLF & _
"0,0,1,0" & @CRLF & _
"0,0,0,100" & @CRLF & _
"1,100,0,0 " & @CRLF & _
"1,0,1,0" & @CRLF & _
"1,0,0,100" & @CRLF & _
"0,100,1,0" & @CRLF & _
"0,100,0,100" & @CRLF & _
"0,0,1,100" & @CRLF & _
"1,100,1,0" & @CRLF & _
"1,100,0,100" & @CRLF & _
"1,0,1,100" & @CRLF & _
"0,100,1,100" & @CRLF & _
"1,100,1,100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")