re = /^0,(?!0,)[^,]+,1,(?!0)[^,]+$/m
str = '1,0,0,0
0,100,0,0
0,0,1,0
0,0,0,100
1,100,0,0
1,0,1,0
1,0,0,100
0,100,1,0
0,100,0,100
0,0,1,100
1,100,1,0
1,100,0,100
1,0,1,100
0,100,1,100
1,100,1,100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end