using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^a-zA-Z0-9](?<![^\x00-\x7F]))+";
string input = @"'[MV] SUNMI(선미) _ 누아르(Noir)'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}