import re
regex = re.compile(r"(?:[^a-zA-Z0-9](?<![^\x00-\x7F]))+")
test_str = "'[MV] SUNMI(선미) _ 누아르(Noir)'"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")