using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img(?<prepend>[^>]+?)src=('|"")?(?<src>[^\2>]+)[\2]?(?<append>[^>]*)>";
string input = @"<img src=""aaa.jpg"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}