$re = '/<img(?<prepend>[^>]+?)src=(\'|")?(?<src>[^\2>]+)[\2]?(?<append>[^>]*)>/';
$str = '<img src="aaa.jpg">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);