#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]+.*\.\s*\n"
Local $sString = ""TRIBUNAL DE JUSTIÇA" & @CRLF & _
"PODER JUDICIÁRIO" & @CRLF & _
"SãO PAULO" & @CRLF & _
"VOTO Nº 6816 2" & @CRLF & _
"AGRAVO DE EXECUçãO PENAL Nº 0001899-54.2017.8.26.0158" & @CRLF & _
"AGRAVANTE: MINISTéRIO PúBLICO DO ESTADO DE SãO PAULO AGRAVADO: MATHEUS MENEZES" & @CRLF & _
"COMARCA: SANTOS VOTO Nº 6816" & @CRLF & _
"AGRAVO EM EXECUÇÃO PENAL. TRÁFICO PRIVILEGIADO. CáLCULOS - AFASTAMENTO DA HEDIONDEZ. IMPOSSIBILIDADE. A PREVISãO DA MINORANTE NãO AFASTA A TIPIFICAçãO DE SUA CONDUTA NO ART. 33, “CAPUT”, DA LEI 11.343/06, CRIME QUE é CONSIDERADO EQUIPARADO A HEDIONDO PELO ART. 2º DA LEI 8.072/90. AGRAVO MINISTERIAL PROVIDO . " & @CRLF & _
"O MINISTéRIO PúBLICO INTERPõE O PRESENTE AGRAVO EM EXECUçãO PENAL COM FUNDAMENTO NO ARTIGO 197 DA LEP, EM FACE DA R. DECISãO PROFERIDA PELO MM. JUIZ DA VARA DAS EXECUçõES CRIMINAIS DE SãO JOSé DO RIO PRETO, QUE RATIFICOU OS CáLCULOS APRESENTADOS, DESCONSIDERANDO A HEDIONDEZ DO CRIME PRATICADO PELO SENTENCIADO MATHEUS MENEZES , CONDENADO PELA PRáTICA DO CRIME DE TRáFICO DE DROGAS, COM BASE NA RECENTE DECISãO DO STF E PROMOVEU-O AO REGIME SEMIABERTO.""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")