package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]+.*\.\s*\n`)
var str = `"TRIBUNAL DE JUSTIÇA
PODER JUDICIÁRIO
SãO PAULO
VOTO Nº 6816 2
AGRAVO DE EXECUçãO PENAL Nº 0001899-54.2017.8.26.0158
AGRAVANTE: MINISTéRIO PúBLICO DO ESTADO DE SãO PAULO AGRAVADO: MATHEUS MENEZES
COMARCA: SANTOS VOTO Nº 6816
AGRAVO EM EXECUÇÃO PENAL. TRÁFICO PRIVILEGIADO. CáLCULOS - AFASTAMENTO DA HEDIONDEZ. IMPOSSIBILIDADE. A PREVISãO DA MINORANTE NãO AFASTA A TIPIFICAçãO DE SUA CONDUTA NO ART. 33, “CAPUT”, DA LEI 11.343/06, CRIME QUE é CONSIDERADO EQUIPARADO A HEDIONDO PELO ART. 2º DA LEI 8.072/90. AGRAVO MINISTERIAL PROVIDO .
O MINISTéRIO PúBLICO INTERPõE O PRESENTE AGRAVO EM EXECUçãO PENAL COM FUNDAMENTO NO ARTIGO 197 DA LEP, EM FACE DA R. DECISãO PROFERIDA PELO MM. JUIZ DA VARA DAS EXECUçõES CRIMINAIS DE SãO JOSé DO RIO PRETO, QUE RATIFICOU OS CáLCULOS APRESENTADOS, DESCONSIDERANDO A HEDIONDEZ DO CRIME PRATICADO PELO SENTENCIADO MATHEUS MENEZES , CONDENADO PELA PRáTICA DO CRIME DE TRáFICO DE DROGAS, COM BASE NA RECENTE DECISãO DO STF E PROMOVEU-O AO REGIME SEMIABERTO."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}