# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n\n/\nabc\n/gm;t' <<< "cmkcwlkmwfergneg
cmkcwlkmwfergneg
cmkcwlkmwfergneg
cmkcwlkmwfergneg
cmkcwlkmwfergneg
cmkcwlkmwfergneg
cmkcwlkmwfergneg
cmkcwlkmwfergneg
cmkcwlkmwfergneg
cmkcwlkmwfergneg"