package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+)\s+is\s+(\d+)`)
var str = `A boy is 31 and girl is 22.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}