$re = '/(\S+)\s+is\s+(\d+)/m';
$str = 'A boy is 31 and girl is 22.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);