package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(((\+44\s?\d{4}|\(?0\d{4}\)?)\s?\d{3}\s?\d{3})|((\+44\s?\d{3}|\(?0\d{3}\)?)\s?\d{3}\s?\d{4})|((\+44\s?\d{2}|\(?0\d{2}\)?)\s?\d{4}\s?\d{4}))(\s?\#(\d{4}|\d{3}))?$`)
var str = `+447222555555
+44 7222 555 555
(0722) 5555555 #2222
07222 55555
(07222) 555555
(07222) 555555
(+447222)555555
+44(7222)555555
(0722) 5555555 #22
+4401612223333
+44(0)1612223333
+441612223333
+44 1612223333
+44(0)161 2223333
+44(0)161 222 3333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}