import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((\\+44\\s?\\d{4}|\\(?0\\d{4}\\)?)\\s?\\d{3}\\s?\\d{3})|((\\+44\\s?\\d{3}|\\(?0\\d{3}\\)?)\\s?\\d{3}\\s?\\d{4})|((\\+44\\s?\\d{2}|\\(?0\\d{2}\\)?)\\s?\\d{4}\\s?\\d{4}))(\\s?\\#(\\d{4}|\\d{3}))?$";
final String string = "+447222555555\n"
+ "+44 7222 555 555\n"
+ "(0722) 5555555 #2222\n"
+ "07222 55555\n"
+ "(07222) 555555\n"
+ "(07222) 555555\n\n"
+ "(+447222)555555\n"
+ "+44(7222)555555\n"
+ "(0722) 5555555 #22\n\n"
+ "+4401612223333\n"
+ "+44(0)1612223333\n"
+ "+441612223333\n"
+ "+44 1612223333\n"
+ "+44(0)161 2223333\n"
+ "+44(0)161 222 3333";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}