package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(can)\b`)
var str = `Can you can a can as a canner can can a can`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}