$re = '/\b(can)\b/mi';
$str = 'Can you can a can as a canner can can a can';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);