using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<leftText>.*?)\[(?<string>\(%(?<param>.+?)%(?<sign>.+?)(?<condition>.+?)\)).+?(?<ifTrue>\{(?<outputTrue>.+?)\|(?<paramSetTrue>.+?)\}):(?<ifFalse>\{(?<outputFalse>.+?)\|(?<paramSetFalse>.+?)\})\](?<rightText>.*)";
string input = @"тут какой то рандомный ненужный текст [(%RANDOM[0,1]%=0) {налево|%DIRECTION%=left}:{направо|%DIRECTION%=right&%SOME_ANOTHER_PARAM%=1}] тут какой то рандомный ненужный текст";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}