const regex = /(?<leftText>.*?)\[(?<string>\(%(?<param>.+?)%(?<sign>.+?)(?<condition>.+?)\)).+?(?<ifTrue>\{(?<outputTrue>.+?)\|(?<paramSetTrue>.+?)\}):(?<ifFalse>\{(?<outputFalse>.+?)\|(?<paramSetFalse>.+?)\})\](?<rightText>.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<leftText>.*?)\\[(?<string>\\(%(?<param>.+?)%(?<sign>.+?)(?<condition>.+?)\\)).+?(?<ifTrue>\\{(?<outputTrue>.+?)\\|(?<paramSetTrue>.+?)\\}):(?<ifFalse>\\{(?<outputFalse>.+?)\\|(?<paramSetFalse>.+?)\\})\\](?<rightText>.*)', 'g')
const str = `тут какой то рандомный ненужный текст [(%RANDOM[0,1]%=0) {налево|%DIRECTION%=left}:{направо|%DIRECTION%=right&%SOME_ANOTHER_PARAM%=1}] тут какой то рандомный ненужный текст`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}