const regex = /(?<!\S)(?P<set>
(?:(?P<a>A) | (?P<b>B) | (?P<c>C))
(?:
(?(a) (?!A))
(?(b) (?!B))
(?(c) (?!C))
(?&set)
)?
)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)(?P<set>
(?:(?P<a>A) | (?P<b>B) | (?P<c>C))
(?:
(?(a) (?!A))
(?(b) (?!B))
(?(c) (?!C))
(?&set)
)?
)\\s', 'gm')
const str = `ABC ACB AB AC
BAC BCA BA BC
CAB CBA CA CB
A B C
AA BB CC
ABD ACD
BAD BCD
CAD CBD
AAA AAB ABA BAA AAC ACA CAA
BBB BBA BAB ABB BBC BCB CBB
CCC CCA CAC ACC CCB CBC BCC
ABCA ABCB ABCC ABCX ABCY ABCZ
ACBA ACBB ACBC ACBX ACBY ACBZ
BACA BACB BACC BACX BACY BACZ
BCAA BCAB BCAC BCAX BCAY BCAZ
CABA CABB CABC CABX CABY CABZ
CBAA CBAB CBAC CBAX CBAY CBAZ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}