import Foundation
let pattern = #"""
(?<!\S)(?P<set>
(?:(?P<a>A) | (?P<b>B) | (?P<c>C))
(?:
(?(a) (?!A))
(?(b) (?!B))
(?(c) (?!C))
(?&set)
)?
)\s
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
ABC ACB AB AC
BAC BCA BA BC
CAB CBA CA CB
A B C
AA BB CC
ABD ACD
BAD BCD
CAD CBD
AAA AAB ABA BAA AAC ACA CAA
BBB BBA BAB ABB BBC BCB CBB
CCC CCA CAC ACC CCB CBC BCC
ABCA ABCB ABCC ABCX ABCY ABCZ
ACBA ACBB ACBC ACBX ACBY ACBZ
BACA BACB BACC BACX BACY BACZ
BCAA BCAB BCAC BCAX BCAY BCAZ
CABA CABB CABC CABX CABY CABZ
CBAA CBAB CBAC CBAX CBAY CBAZ
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)