using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^X]{0,3}a)[^\nX]*X";
string input = @"aaaaaaaaX
baaaaaaaaX
bbaaaaaaaaX
bbbaaaaaaaaX
bbbbaaaaaaaaX
babaaaaaaaaX
aX
abaaX";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}