import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^X]{0,3}a)[^\\nX]*X";
final String string = "aaaaaaaaX\n"
+ "baaaaaaaaX\n"
+ "bbaaaaaaaaX\n"
+ "bbbaaaaaaaaX\n"
+ "bbbbaaaaaaaaX\n"
+ "babaaaaaaaaX\n"
+ "aX\n"
+ "abaaX";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}