$re = '/^(?!.*ess|ence|sports|riding?$).*/m';
$str = 'harness
no sports
sports more words
ridin
riding
riding ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);