re = /^(?!.*ess|ence|sports|riding?$).*/m
str = 'harness
no sports
sports more words
ridin
riding
riding '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end