using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"from=<(.+?)>,";
string input = @"Jul 10 10:09:08 srv24-s-st postfix/qmgr[3043]: 25E6CDF04F4: from=<testmail@email.ru>, size=617951, nrcpt=1 (queue active)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}