re = /from=<(.+?)>,/m
str = 'Jul 10 10:09:08 srv24-s-st postfix/qmgr[3043]: 25E6CDF04F4: from=<testmail@email.ru>, size=617951, nrcpt=1 (queue active)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end