$re = '/ *(\w+|\/[^\/\\\\]*(?:\\\\.[^\/\\\\]*)*\/) */';
$str = '/some test/ -> next data
prev<-/now/->/how about this/
asd<-/rege\\/x/
/\\/\\//
/\\\\/
/^\\d+$/ <- /\\./
/\\./ -> /\\d/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);